Serendipity 1.7.4 released

Serendipity 1.7.4 has just been released, addressing a few PHP 5.3+ compatibility issues for plugins and libraries, the most relevant changes are::

  • Updated textile plugin for PHP 5.3+ compatibility
  • Updated spamblock captcha creation for PHP 5.3+
  • Updated Smarty library
  • Improved .htaccess "deny" method for the Spamblock plugin

You can upgrade as usual by downloading the release files and uploading them to your webspace.

PLEASE NOTE - Due to a bug in the textile plugin, it currently requires PHP 5.3 to operate. Also, loading the list of plugins in environments with PHP < 5.3 can fail. We are working on an update and will release this fix in 1.7.5.

Have fun using Serendipity, and thanks to users who report issues like these to the forums, and of course to our hardworking developers like Yellowled, mattsches, onli and Ian who quickly address these issues (says Garvin, who was on winter vacation *g*).

Trackbacks

Trackback specific URI for this entry

  • No Trackbacks

Comments

Display comments as (Linear | Threaded)

Hanno on at :

I wonder if you have a policy how long you support old PHP versions. PHP 5.2 dropped out of support by upstream in 2011. So everyone still using it is putting users at high risks of security vulnerabilities. And even PHP 5.3 will reach end of life pretty soon.
I wouldn't bother fixing compatibility issues with old PHPs forever.

Garvin on at :

Our policy is that 1.7 is our final "compatibility" release, which we do want to have compatible to PHP 5.2 if possible. For our 2.0 tree we develop with PHP 5.4 in mind.

Apart from that, I agree with you!

Add Comment

E-Mail addresses will not be displayed and will only be used for E-Mail notifications.

To prevent automated Bots from commentspamming, please enter the string you see in the image below in the appropriate input box. Your comment will only be submitted if the strings match. Please ensure that your browser supports and accepts cookies, or your comment cannot be verified correctly.
CAPTCHA

BBCode format allowed