Apply markup plugins per-entry

In the past, several users wanted the ability to tell Serendipity that specific markup plugins shall not be applied to specific entries.

Until now, Serendipity applied markup plugins globally to every entry, without any distinction. Today I have committed a patch that enhances the "Extended options of Entries" plugin to specify, if specific markup plugins should NOT be applied to an entry.

This now enables you to create entries where you don't want to use the nl2br or Wiki markup. Plus, with some basic coding skills you can add new markup plugins which don't affect past entries, if you create the required entryproperty for those past entries that disable the markup plugin.

The feature has been committed to the SVN 1.1-alpha trunk and also to the affected plugins in our Spartacus repository. The change is backwards compatible, so nothing will change if you either don't use the functionality or do not make any settings to the list of disabled markups.

Trackbacks

Trackback specific URI for this entry

  • No Trackbacks

Comments

Display comments as (Linear | Threaded)

Steve on at :

Sounds great, although the 1.0 release isn't finished yet and these improvements are being applied to 1.1.

I'm still waiting to upgrade my blog to 1.0. It will be interesting seeing the new themes and the large number of bugfixes that are reported here :)

Garvin on at :

That's right. We do not want to affect the stability of the current 1.0 release, so no new features are added to that branch.

We are currently working on improving our PR texts and the design/content of our website(s). When that is done, 1.0 will be released. The 1.0-beta1 can currently be used quite well until then. Upgrading is very easy, as usual.

But we don't really have a "large number of bugfixes". Compared to the 100+ required bugfixes in a WP release, we only have to offer 10+ bugfixes. Go figure. ;-)

Nice to hear that you are eagerly waiting for the release! You'll definitely have fun with it. :-)

Steve on at :

I'm a little leery of using beta versions of any software, serendipity in particular because version 0.81-beta (or was it 0.71?) contained many bugs that frustrated some users of my site.

I'm not saying that's your fault. Beta versions are supposed to contain bugs, or else they would be release versions. Still, I'd rather wait until the stable release is available.

It seems that with every additional programming job I've had, the more I realize the value of stability over features. Stability is definitely harder to achieve, which is why I'm glad you're taking your time to get it right :)

Keep up the good work!

Add Comment

E-Mail addresses will not be displayed and will only be used for E-Mail notifications.

To prevent automated Bots from commentspamming, please enter the string you see in the image below in the appropriate input box. Your comment will only be submitted if the strings match. Please ensure that your browser supports and accepts cookies, or your comment cannot be verified correctly.
CAPTCHA

BBCode format allowed